iRule  Universal Remote Control

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Panasonic PT-AE6000E RS232 the projector does nothing

Frank Nov 21, 2017 01:46PM EST

I am trying to use an iTach Ethernet to Serial adapter (IP2SL) to remote control my Panasonic PA-AE6000E. But it seems that the projector does not show any reaction, there is no response on the RS232. Nothing. I have tried several methods of communication but it simply does not happen anything:

1. iRule by using the available PT-QE4000 codes that are available in the software. The codes seem to be the same as in the manual for the PT-AE6000E. --> the projector does nothing

2. I wrote a quick programm in node.js that opens a socket connection to the iTach and port 4999 and send the string manually. --> the projector does nothing

3. I have used a little helper programm from the iTach company (GScan.exe) that connects to the iTach and lets you send strings via a windows GUI to the device --> the projector does nothing.

There is even no response with an error code or similar, the communication is absolutly dead.

When using methods 1-3 communication with the iTach via TCp itself works fine. ITAch is responsive and it will send responses via TCP when connected to socket 4998 as it is supposed to when I use its API calls. But when connected to socket 4999 which should simply route strings untouched to the RS232 --> nothing happens.

I am using a 1:1 9 pin serial cable. I have also tried a crossed cable (nullmodem cable) but this changes nothing.

Serial commmunication is configured according to the Panasonic requirements (SERIAL,1:1,9600,FLOW_NONE,PARITY_NO).

Any ideas what's going wrong?

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Recent Discussions

Ajax-loader-small
customer-service@iruleathome.com
https://cdn.desk.com/
false
iruleathome
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
true
Invalid characters found
/customer/en/portal/articles/autocomplete
There was an error contacting Get Satisfaction
View All
0
discussions
replies
Questions
Ideas
Problems
Praise