iRule  Universal Remote Control

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Sony TV IP Control loose connection

Jason May 02, 2017 03:48PM EDT

Hi

After weeks of struggling through the setup for registering iRule to work with my Sony TV, I am still having problems after getting it to work reliably...
TV: 2016 model - Sony XBR75X940D

I used the instructions here to register...
https://getsatisfaction.com/irule/topics/using_sony_ip_control_for_discrete_input_changes_on_2013_xbr


I have created a temp button to complete the registration, and I am able to successfully register. After I click the button, all other buttons start working for the TV.

Now the problem...

When I walk away or leave the house (not sure on specific cause yet), I am unable to control the TV again. If I click the temp register button again, it starts to work again instantly. I don't need to do the browser part 2nd time, just the iRule register button part. I can even turn on and off TV with the iRule once its working. But then it will quit again and need me to push the register button I created again....

Now this is a little less than convenient and have no use for this if I can't get the TV to work. Please HELP!!!

-JASON

8 Community Answers

Best Answer
Alex Milogradov May 02, 2017 04:04PM EDT

Jason,

All you need to do is this:

Set Access Control to "Normal and Pre-Shared Key", Pre-shared Key set to 1111 and Set Simple IP Control to On. You need to import "SONY TV - IP Control 2015 Models" device driver.

View in conversation


Up -1 rated Down
Alex Milogradov Best Answer May 02, 2017 04:04PM EDT Builder & App Support Support
Jason,

All you need to do is this:

Set Access Control to "Normal and Pre-Shared Key", Pre-shared Key set to 1111 and Set Simple IP Control to On. You need to import "SONY TV - IP Control 2015 Models" device driver.

Up 0 rated Down
Jason May 02, 2017 06:52PM EDT
Hi Alex,

Thanks for your reply. I have already completed these steps, and I am able to control the TV in every way. Then at some point it quits working again. It appears to be when the app on the phone is closed and then re-opened. The next time I go to use it, it won't work. I have to then use the temp button created to complete the registration again to make it work again.... I do this over and over every time I start this app.....

It is as if iRule is creating a different unique identifier of some kind each time it starts, so my TV doesn't recognize the phone the next startup!

I have to send this to the TV again every time it quits working. I am really surprised no one with a 2016 sony has not had this problem yet...
/sony/accessControl?
{"id":13,"method":"actRegister","version":"1.0","params":[{"clientid":"iRule:1","nickname":"iRule"},[{"clientid":"iRule:1","value":"yes","nickname":"iRule","function":"WOL"}]]}
Up 0 rated Down
Alex Milogradov May 02, 2017 07:25PM EDT Builder & App Support Support
I have 850c and 850D and 940D TVs and do not have to register the TV. Simply do what I said in the previous response.
Up 0 rated Down
JAson May 02, 2017 07:53PM EDT
If I only do these three steps , I get absolutely nothing.

Set Access Control to "Normal and Pre-Shared Key", Pre-shared Key set to 1111 and Set Simple IP Control to On. You need to import "SONY TV - IP Control 2015 Models" device driver.


I don't understand why you say 'do not have to register the TV'. You have to register the device to control the TV and just registering with Sony's Video & TV Sideview app is not enough. From what I have read is you have to use the steps I posted, which I have been able to get it to work . Only temporarily. As soon as I close iRule on my phone and re-open it stops working.
Up 0 rated Down
Jason May 02, 2017 08:17PM EDT
This is what I followed to get it to work and the steps you mentioned are part of this...

https://getsatisfaction.com/irule/topics/sony-4k-2014-tv-ip-control-authentication

Up 0 rated Down
Jason Bruns May 03, 2017 11:15PM EDT
This is the only way I can get it to TEMPORARILY WORK

On TV

1) Set to "Normal and Pre-Shared Key"
2) Set key to 1111
3) Simple IP Control "On"


on Computer:

1. Install Google Chrome
2. Install Simple Rest Client (https://chrome.google.com/webstore/detail/simple-rest-client/fhjcajmcbmldlhcimfajhfbgofnpcjmb)
3. Once Simple Rest Client is installed you should a blue globe looking icon to the right of the URL field in Chrome. Click on that icon.
4. In the URL field of the REST Client, type in http://192.168.1.31/sony/accessControl where you replace 192.168.1.31 with IP address of your TV.
5. Click on POST.
6. In the DATA field paste {"id":13,"method":"actRegister","version":"1.0","params":[{"clientid":"iRule:1","nickname":"iRule"},[{"clientid":"iRule:1","value":"yes","nickname":"iRule","function":"WOL"}]]}
7. Hit SEND. You should see a message on TV pop-up with PIN code and a Username and Password message pop-up in the Browser. Leave Username blank and in password field put in the PIN code that is displayed on TV.


If successful, see the message on TV about successful pairing.


IRULE SIDE.

Now go into iRule builder.

1. Browse for Devices under Community tab.
2. Search for Type=TV+Vendor=Sony+Codes Type=IP (see attached screenshot) and import the device.
3. In the builder, add a "device-network code(right click network codes)". Give it name REGISTER and paste
/sony/accessControl?{"id":13,"method":"actRegister","version":"1.0","params":[{"clientid":"iRule:1","nickname":"iRule"},[{"clientid":"iRule:1","value":"yes","nickname":"iRule","function":"WOL"}]]}

4. Create a button and drag and drop the REGISTER command from the device you just imported.
4. Create another button with one of the INPUT commands. This is just for testing.
5. Save and Sync.
6. Assign this device to the same gateway as the other Sony TV device that you have.
7. Pressing the button created.
8. Try other buttons and they now work including turning on and off tv.

YEAH!!! Celebrations!!

Close the app and re-open and it does NOT work... WTF @#$@#$@$%#

click the button 'REGISTER' button again and it starts working again...
Up 0 rated Down
Alex Milogradov May 03, 2017 11:17PM EDT Builder & App Support Support
Jason,

What driver did you import in the builder? Need exact name.



Alex
Up 0 rated Down
Jason May 04, 2017 12:51PM EDT
"SONY TV - IP Control 2015 Models" - I cleaned out everything from iRule multiple and reloaded device from scratch mulitple times over in my troubleshooting. I tried it with only this device configured alone and nothing else and with other devices working and results never changed. I also tried the other sony IP control devices with no success

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Recent Discussions

Ajax-loader-small
customer-service@iruleathome.com
https://cdn.desk.com/
false
iruleathome
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
true
Invalid characters found
/customer/en/portal/articles/autocomplete
There was an error contacting Get Satisfaction
View All
0
discussions
replies
Questions
Ideas
Problems
Praise